一千萬個為什麽

搜索

Grails - 試圖包含HTPPBuilder - 鏈接錯誤


當我運行 grails install-dependency 時,我明白了。

java.lang.LinkageError: loader constraint violation: loader (instance of ) previously initiated loading for
    a different type with name "org/xml/sax/SAXParseException"

怎麽了?我之前沒有使用過Grails依賴管理,這是相當神秘的。

repositories {        
    grailsPlugins()
    grailsHome()
    mavenLocal()
    mavenCentral()
}

dependencies {
     runtime 'org.codehaus.groovy.modules.http-builder:http-builder:0.5.0'
}

最佳答案

看起來像xml-apis沖突,

嘗試

dependencies {
     runtime 'org.codehaus.groovy.modules.http-builder:http-builder:0.5.0'{
         excludes 'xml-apis'
     }
}

轉載註明原文: Grails - 試圖包含HTPPBuilder - 鏈接錯誤

猜你喜歡