一千萬個為什麽

搜索

Expression Blend 2問題與創建Silverlight 2項目?

我有Expression Blend 2,Service Pack 1,並且無法創建Silverlight 2項目。當我嘗試創建Silverlight 2項目時,出現以下錯誤:

Blend無法繼續,因為無法找到兼容的Silverlight版本。

幾周前我安裝了Blend,昨天服務包裝好了。我做的事情如下:

  1. Visual Studio 2008 Developer Team Edition
  2. SQL Server Management Studio 2008
  3. 表達式Web 2
  4. Expression Blend 2(2 - 5星期前)。
  5. Silverlight SDK 2(昨天)
  6. Expression Blend 2 SP1(已下載,然後安裝,昨天)
  7. Expression Blend 2 SP1(昨天在​​閱讀這是在線
  8. 適用於Visual Studio 2008的Silverlight工具(昨天放棄Blend後)

除了這兩個鏈接中描述的技術(我已經用盡,沒有任何工作),有沒有人有任何建議?建議不涉及卸載和重新安裝我的整個dev堆棧? :)

哦,為了它的價值,我在64位Vista上。但是,Expression是一款32位應用程序(當然,運行時間僅為32位)。

我已經(基本上)在 Blend自己的論壇。如果我在那裏得到回應,我會在這裏發布,以防其他人遇到此問題。

最佳答案

你安裝了什麽版本的Blend(版本號,而不是Service Pack)?

根據此表單發帖,問題將從以下方面解決:

該文件的舊版本也命名為BlendV2SP1_en.exe,其大小為18,241 KB無法正常工作。微軟在2008年10月16日早上和10月17日早上更新了這個服務包。

並有更詳細的解釋:

更新您的混合版本2.1.1693至2.1.1760.0

另外,我沒有看到任何Silverlight運行時的安裝。你是否也有過這種情況?

轉載註明原文: Expression Blend 2問題與創建Silverlight 2項目?