一千萬個為什麽

搜索

將Ruby升級到1.9

我在C:\ Ruby及其下面的寶石上安裝了ruby v 1.8。 我打算升級到v 1.9,它的安裝程序嘗試將應用程序默認為c:\ ruby 1.9

我該如何處理,以免破壞我的舊寶石..包括Rails等?

謝謝

最佳答案

使用RubyInstaller,我可以同時安裝Ruby 1.8和1.9嗎?

A: Yes. By using the RubyInstaller, ruby 1.8 will be installed by default to C:\Ruby, while 1.9 will be installed to C:\Ruby19. This is by design as Ruby 1.8 and 1.9 offer a different API that may interfere with some RubyGems.

Source: http://wiki.github.com/oneclick/rubyinstaller/faq#dual_install

所以繼續使用安裝到C:\ Ruby19的默認值

轉載註明原文: 將Ruby升級到1.9