一千萬個為什麽

搜索

成功的自動/自動PAgP端口通道?

思科文檔在形成渠道時聲明如下:

SW1               SW2
----------------------------------------
On                 On              = Yes
Auto/Desirable     Desirable       = Yes
On/auto/desirable  Not configured  = No
On                 Desirable       = No
Auto/On            Auto            = No

據我所知,Auto只響應PAgP,但不會啟動PAgP協商。但出於某種原因,使用Auto測試雙方時,端口通道仍會出現。

SW1#show etherchannel summary 
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+----------------------------------------------

1      Po1(SU)           PAgP   Fa0/1(P) Fa0/2(P) 

我的問題是, Auto - Auto 配置是否應該失敗?為什麽這樣做?


編輯

兩個開關配置

交換機1 </強>


Building configuration...

Current configuration : 1131 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW1
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 channel-group 1 mode auto
 switchport mode trunk
!
interface FastEthernet0/2
 channel-group 1 mode auto
 switchport mode trunk
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Port-channel 1
 switchport mode trunk
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

切換2

Current configuration : 1134 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW2
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 channel-group 1 mode auto
 switchport mode trunk
!
interface FastEthernet0/2
 channel-group 1 mode auto
 switchport mode trunk
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Port-channel 1
 switchport mode trunk
!
interface Vlan1
 ip address 192.168.1.2 255.255.255.0
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

最佳答案

默認情況下,etherchannel以“靜默”模式運行。所以ethch第一次上升,但如果你嘗試禁用/啟用側面,也許ethch不會再次上升。

來自CISCO CCO: 非靜默 - (可選)如果您的交換機連接到支持PAgP的夥伴,請在端口處於自動或所需模式時配置交換機端口以進行非靜默操作。如果未指定非靜默,則假定為靜默。靜默設置用於連接文件服務器或數據包分析器。此設置允許PAgP操作,將端口連接到通道組,以及使用端口進行傳輸。

轉載註明原文: 成功的自動/自動PAgP端口通道?