一千萬個為什麽

搜索

簡單的持久性框架與macruby兼容?

我在使用帶有ActiveRecord(w/sqlite3)的macruby或續集時遇到了問題。還有其他建議嗎?我需要一個簡單的輕量級持久性機制來嵌入我的應用程序中,它可以處理少於5個表,最多可以處理數萬行。

最佳答案

以下組合有效:

MacRuby 0.8
sqlite3-ruby gem 1.3.2
sequel gem 3.18.0
OSX 10.6.5

訣竅是卸載'sqlite3'寶石並安裝'sqlite3-ruby'。

轉載註明原文: 簡單的持久性框架與macruby兼容?